PlayStation 5 Reportedly Has More Incompatible PS4 Titles

PlayStation 5 and accessories

According to a new report, a few more PS4 titles are incompatible with the next-gen console PlayStation 5.

Media outlet ThisGenGaming recently revealed that there are six more PS4 titles that were not backwards compatible with the PS5, which were not revealed by Sony Interactive Entertainment. These titles are:

  • Pool Nation
  • Tower of Time
  • The Gardens Between
  • PixelBOT EXTREME!
  • YIIK: A Postmodern RPG
  • Golem (PSVR)

The good news, however, is that after the developer was notified, PixelBOT EXTREME! got fixed and now backwards compatible with the next-gen PlayStation console. The rest are still not able to play on the PS5, unfortunately. It was also revealed on the PSN Store that the description states on each of these titles say that it can only be played on PS4.

This list of games now adds to the other titles that are not compatible with the PS5 and also with those from Ubisoft. SIE has not confirmed these titles yet, but sooner or later they might make this official.

PlayStation 5 is now available in the US, Japan, and select few countries. The rest of the world will get it on November 19.

Source: ThisGenGaming